Velociraptor CPU 100% load - Facerig

Homepage Forum Support FaceRIG Bug Report Velociraptor CPU 100% load

This topic contains 7 replies, has 2 voices, and was last updated by  facerig 2 years, 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #72080

    DongWoo
    Participant

    When you use the Velocity Raptor character
    I am having a problem that uses 100% of CPU resources.
    This will prevent you from using FaceRig at all.

    View post on imgur.com

    View post on imgur.com

    • This topic was modified 2 years, 3 months ago by  DongWoo.
    #72082

    DongWoo
    Participant
    #72095

    facerig
    Keymaster

    Hi,

    Adding FaceRig to your streaming configuration (stream software + game) will add some CPU/GPU load. Note that face tracking and high quality rendering come with the CPU and GPU resource cost, so if you are running a game at high quality graphics option, you may have frame drops.

    There are some things that you can do to make FaceRig footprint smaller on your setup:
    1. use FaceRig at a lower resolution, you can go as low as 960×540. I assume you are using FaceRig as webcam view, so the view is already small.
    2. use a lower setting in the game you are streaming, after all, you are basically streaming two games (resource wise)
    3. use window capture instead of FaceRig Virtual Webcam and disable Broadcast. There is an option to hide the interface.
    4. limit FaceRig’s refresh rate to 24-30 fps. Go to General Options, Performance Tab.

    We have streamed on twitch, and we had no issue on a mid-range computer (i5-4690 and nVidia GTX 750). We streamed Rocket League and Don’t Starve with FaceRig running as a facecam. Unfortunately, the vods aren’t available anymore.

    #72096

    DongWoo
    Participant

    This is not a performance issue.
    Normally the normal load rate is 10 ~ 15%.
    However, there is a high probability of abnormal symptoms and the load rate is increased by 100%.
    This is considered a programming problem, not an option problem.
    Also, characters other than Velociraptor have no symptoms at all.

    Below is the video recording the abnormal symptoms.

    #72112

    facerig
    Keymaster

    Hi,

    If you have added the hands from the Intel camera, we recommend that you remove them as it may be the cause of the spikes.

    #72144

    DongWoo
    Participant

    I followed the instructions, but I still have problems…… T_T

    #72148

    DongWoo
    Participant

    We have identified the cause of the problem.
    This is a problem that occurs when you turn on the real sense camera.
    I do not think I can use RealSense camera technology until the problem is resolved.

    #72200

    facerig
    Keymaster

    Hi,

    In this case, please write a message to the Realsense support, they should investigate this issue on their side.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.


Privacy Preference Center

  • Warning: reset() expects parameter 1 to be array, string given in /usr/local/important/web/wp.facerig.com/wp-content/plugins/gdpr/public/partials/privacy-preferences-modal.php on line 33
Warning: Invalid argument supplied for foreach() in /usr/local/important/web/wp.facerig.com/wp-content/plugins/gdpr/public/partials/privacy-preferences-modal.php on line 93