Facerig can't find face when discord is running - Facerig

Homepage Forum Support FaceRIG Bug Report Facerig can't find face when discord is running

This topic contains 2 replies, has 2 voices, and was last updated by  Genesis 2 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #71898

    Genesis
    Participant

    Since around two weeks I’ve had this strange issue, that, when I already have discord running, facerig can’t find my face. My webcam lights up when I open facerig, but I can’t adjust my head position or expressions and my facerig avatar ain’t moving.
    I have to close discord entirely, restart facerig and then it works. And I can re-open discord, too, and it won’t interfere any further.
    This is still weird, annoying and shouldn’t happen.

    #71912

    facerig
    Keymaster

    Hi,

    Thanks for reporting this issue, we have never tried using Discord so we hadn’t found this yet.
    But what you are describing sounds like Discord somehow accesses your camera and that is why you can not use it in FaceRig as well.
    Here is a forum thread about such issues:
    http://steamcommunity.com/app/274920/discussions/2/451850468375624974/

    #72006

    Genesis
    Participant

    Hi there,
    by now I’ve tried out a list of things and I thought I’d keep you up to date, in case there are more users showing up with similar issues.

    The software mentioned in your link couldn’t find any other programs using my webcam, even with discord open. For the longest while closing discord and then opening facerig solved the issue for me. A few days ago I tried changing settings within discord. What made the difference was setting the microphone device in discord from “Realtek” to “Default”. Yes. That way round. It makes no utter sense, but that also solved the issue for me.

    Another thing that troubled me shortly after was Nvidia experience. I had my computer restarted, discord closed and my webcam software was showing a proper picture. But as soon as I started facerig, it wouldn’t find my face – again. Showing the webcam on facerig resulted into a black box, instead of my face.
    I closed facerig and my webcam software itself also showed a black screen only. Only unplugging and replugging the webcam fixed my webcam. But as soon as i started facerig again, the same trouble started all over again.

    It was a wild guess when, at some point, I turned off Nvidia Experience. Started facerig after that and voila. Everything fixed. Not a coincidence, as my OBS also struggled with any video capture device that day, but as soon as the Nvidia Experience was turned off, OBS was also willing to show either my webcam or my facerig avatar.

    I hope this information will help with eventual future troubleshooting.
    In case you need these peanuts here, have some info on what I am using:

    Webcam: Logitech C920, latest drivers + official Logitech webcam software
    System: Windows 7 Prof. 64 bit
    Graphics Card: Nvidia GeForce GTX 970
    Streaming Software: OBS Studio

    Should there be any other questions just let me know.

    ~Genesis

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.


Privacy Preference Center

  • Warning: reset() expects parameter 1 to be array, string given in /usr/local/important/web/wp.facerig.com/wp-content/plugins/gdpr/public/partials/privacy-preferences-modal.php on line 33
Warning: Invalid argument supplied for foreach() in /usr/local/important/web/wp.facerig.com/wp-content/plugins/gdpr/public/partials/privacy-preferences-modal.php on line 93